1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1988 West-Germany GT(S?) project of nightmares!

Discussion in 'Your 4th Gen beauty' started by Sakke, Jun 23, 2019.

  1. Sakke

    Sakke Member

    So back in 2017 i bought this 1988 Red-ish Celica for 900€ that had 288 000 something kilometers driven and a leaky powersteering pump.
    After a quick visit to a local hydraulics shop for some brand new hoses clamped between the re-used connectors (as instructed by this very same forum) and basic maintenance of oils and filters later it was a solid ride! For about a year...[​IMG]

    At around the 292k mark this 30 year old 3s-gelc's oilpump failed on the highway on my way home and after some hard decision making of "well its already making bad noises, might as well drive for as long as it lets me" instead of towing it home in the middle of the night, i succesfully made it to a halfway point of my grandparents house and hitched a ride home.

    A week or so passed and i arrived with a trailer to get her closer to home for an engine change, and behold! The engine turned on just fine with the turn of the key! However the clanking noise must have been heard for miles around when i drove it on to the trailer :D[​IMG]
     
  2. Sakke

    Sakke Member

    Now that the car was home i started to look for a replacement engine, to save costs and trouble (oh how naive i was back then) i decided to just look for another Gen1 3sge, rip out the old and drop in the new! Well... we all know how that ends up. The project quickly got out of hand when intake/outtake gaskets would have cost 30€ but i found a complete engine gasket set for 40€! So i ended up resealing this "new" engine from Sweden that has atleast 160k on it.
    As well as changing every single gasket there is, i also went through all the bolts and made sure they were torqued to the right specifications.
    [​IMG]
    Now the original engine was a 3s-gelc with all sorts of Emission Control Devices, and the new engine didnt even have an EGR port on the head. So naturally i decided to strip the emission stuff as i went along.
    Opened up the valve covers to see if there was any funny stuff going on, old engine looks brand new![​IMG]
    While the new engine looks all gross and chunky![​IMG]
     
  3. Sakke

    Sakke Member

    Heres the valves before and after cleaning, blasted with some baking soda and washed off the film that remained.[​IMG]
    After cleaning i noticed these nasty marks on the cylinder 1 and 2's head.[​IMG]
    Had the pistons marinade themselves in some penetrating oils in the hopes of loosening up the old pistonrings, wiped all the gunk off with some clean rags! However pistons 1 and 2 are showing some damage similar to the valves above them :([​IMG]
    [​IMG]
     
  4. Sakke

    Sakke Member

    [​IMG]
    At this point i had really ran into some problems with sourcing new injectors. the original injectors green denso 23250-74050 i couldnt find any service kits for, nor could i find refurbished ones anywhere as all the plastic parts were shot and cracked on them.

    In the end after some furious research i found their successors the DENSO 23250 - 70080 that are used in the Supra 7m engine if memory serves me right, costed about 100€ refurbished for a set of 6 so now i have 2 spare ones! (however now that the engine is in and wont start, despite having fuel come up to the rail and spark for the plugs... i wonder if these injectors i have are at fault somehow.)

    2nd huge problem i had was finding disc brakes and right brakepads, you see this unicorn of a car somehow has ABS. In the end i did find the right rotors and pads, maybe i just got lucky.

    The 3rd major hurdle was finding a new O2 sensor, you see this thing has a downstream o2 with 3 wires.. which seemed like an impossible combo to find. Think the one i ended up finding with the correct connector and all is from a Lexus?[​IMG]
     
  5. lone wolf

    lone wolf Well-Known Member Donated!

    Seems like you got yourself a good project there.. Good luck with that, it might be with a different spec engine due to the EGR missing and so on. However, that should be no problem.

    what did you do with the old injectors, try to clean those maybe?
     
  6. Vicdat610

    Vicdat610 Active Member

    Welcome to the "Forum" ... judging by the amount of sludge, it looks like your original engine was better maintained than the replacement. That's typical with "unknowns", so mix and match the best parts to build a reliable 1st gen motor. Back in 2014 I did a valve job on mine with 200K miles (not kilos) on the clock. Now it's past 263K and still on the orig bottom end and ECT auto trans. Mine was clean and sludge-free like yours; it's a California version with the single wire O2 sensor and factory EGR. Engine still has decent compression...160+ across the board.

    It looks like your making fast progress too!

    Vicdat
     
  7. Sakke

    Sakke Member

    Ah yes, fast progress! not at all sadly :( the engine gave out 14 months ago, only got the new engine married to the S53 transmission and put into the car about 2 months ago, now ive still got an exhaust to weld together! My "downpipe" the bit that connects to the exhaust manifold and curves under the car had been mangled by some DIY specialist and it had a 3inch pipeflange welded to it... yeah and to plug the inch of excess space they had used nothing but welding :S it was truly a sight to behold! and for that reason i was unable to change out the tiny 1st muffler someone had put on it, the idle exhaust volume was window breaking basstone drone sound. So to fix this problem i was looking for a replacement downpipe, turns out those are even harder to find than original mufflers :( ended up pulling ST182 exhaust headers and the connecting pipe from the wreckers for 50€ which was a steal! Long banana headers instead of the ST162 cast iron one, also the connecting pipe had exact fit size and location wise for the O2 sensor!

    This picture is from the time i bought the car and fixed some of the exhaust to pass the MOT inspection, here you can see the tiny center muffler... and the reason i decided not to change it out the first time around, made some lifesaving surgery to the old grotty pipe but deemed it impossible to weld a new muffler into.[​IMG]
    So things still to be done to the car currently are as follows - get the damn thing started! Fuel is up to the fuel rail, sparkplugs are happily sparking away! the engine turns nicely so the starter aint to blame. My best guesses are = timing is 180 degrees off, injectors arent firing somehow, o2sensor issue? perhaps one of the bazillion wiringlooms are faulty, or the ECU has passed on to another plane of existence. Or a grounding issue somewhere (judging by the amount of existing ground wires in my engine bay, it seems to have been a common issue)

    I also have yet to replace passenger side brakes, i was planning on resealing the old calipers but i got an amazing deal of factory refreshed calipers! Both front calipers with pads for 30€ from a closeout sale! However i needed to change out 1 single bushing on the lower control arm, and the new control arm i have SOMEHOW has 17mm inner bushing diameter and 17mm outerbushing mount??? yeah the control arm that i need has 20.3mm bushings... im still waiting to hear back from Moog USA if their RK640771 has the correct dimensions before i order another wrong lowercontrol arm
     
  8. Vicdat610

    Vicdat610 Active Member

    Also check the vane-type air flow metre (mine had sketchy wiring) and the bellows (rubber) air hose going to the Throttle Body for tiny cracks....Mine had so many that it ran rough. Finally replaced it with a short ram to the stock airbox and K&N.

    Vicdat
     
  9. Vicdat610

    Vicdat610 Active Member

    Yeah...we call that small muff a resonator (some people will substitute a glas-pack - not recommended :). I's usually used in conjunction with a small turbo-like muffler at the back. My CA car also has the older style cheap cat.
    I like the factory twin-tip look if you can source one.
    (You can got a giant fart-can if you're under 50 years old.....)

    Good luck
    Vicdat
     
  10. Sakke

    Sakke Member

    First time around i got a 2-1/2" 11/19x32cm muffler on it which still was waaaay too loud, as in stay out of the highways loud. So i went and bought the biggest one i could find new in the store which was a "turbo muffler" also 2-1/2" but 11/25x47cm which barely fits under the original heatshield for the rear muffler. But with the turbomuffler i could now drive on highways without excess bleeding from my ears! Still the idle basstone drone was pretty bad. :( Now that i have a usable downpipe with the right size factory flange i also bought the biggest center muffler i could find which pretty much fills the entire transmission tunnel 2-1/2" 12x70cm which looks to be around 3 times the size of the old one... im hoping that with this the sound get at least somewhat close to factory levels. Dont get me wrong tho, i would LOVE a factory exhaust system or at least go down to 2.25" but thats such an uncommon pipesize here in Finland so its just cheaper and a lot more available to continue with the 2 1/2" system. Heres a photo of the smaller muffler, ill update with photos of the new system when i get around to doing it. :)[​IMG]
     
  11. Vicdat610

    Vicdat610 Active Member

    The 2 1/2" system with the big center muff should be pretty quiet. Hopefully it will still be plenty throaty when the TVIS kicks-in....
    hahahah (no t-tec-yo here)

    Vicdat
     

Share This Page